Configuring Cisco Catalyst 9000 series for use with Livewire
Scope
This document covers configuration of the Cisco 9200, 9300 and 9400 series of switches for use with a Livewire+ network.
Introduction
This document is not intended to be an all-inclusive or even a step-by-step manual on how to configure this switch but is provided as a guide and makes some basic assumptions regarding the skill level of the person doing the programming. If you are not comfortable hooking up serial cables, assigning IP addresses, typing in a command-line interface, etc, you should contact your IT department for assistance. If this is the first time the switch has been configured, you will have to connect to the switch via a console cable and serial connection to enter into setup. After the initial configuration of the switch, you can connect to the switch either via a Telnet session or through a serial port. During the initial setup, you will assign the switch an IP address, which will then allow you to connect to the switch via a Telnet session at a later time.
You can connect to this switch using a USB cable and a serial port driver from Cisco.
As of the date of this writing, the Windows USB driver can be obtained from the Cisco website. Make sure you install the driver before connecting the switch to your USB ports. This will install a new COM port on your computer. Use the device manager for your operating system to determine what COM port has been installed. PuTTy is a free terminal program that can be used for configuration and can be downloaded here.
Programming
Once connected with the serial cable (default settings are 9600 baud), you should be able to see messages on the screen as the switch boots. This will confirm that your serial cable is working correctly. If you are prompted to enter any setup wizards, please answer ‘No’.A couple of other notes that might be helpful:
- Many commands can be abbreviated and just need to be unambiguous. For example, the
enable
command is often abbreviated asen
andconfigure terminal
is often abbreviated asconfig t
. All commands can be abbreviated. - The TAB key completes a word and checks it for correctness. For example, if you type ‘en’ and then press TAB it will spell out the word ‘enable’.
- The # (pound or hash sign) indicates you are in privileged mode. For example, if your prompt says Switch> and you try to type config t, you will receive and error because you are not in privileged mode. Typing the enable command will give you the Switch# prompt indicating privileged mode.
Set the passwords
We suggest using a password of ‘Livewire’ or some other password that is easy to remember.
Switch>enable
Switch#configure terminal
Switch(config)#username AAAA password Livewire
Switch(config)#enable password Axia
Set the hostname
We suggest setting the hostname of each switch to something descriptive. Suggestions might be AXIACORE01, or AXIAEDGE01, etc. In this example we will use AXIA01.
To change the hostname from the default of ‘Switch’, type the following from the prompt;
Switch(config)#hostname AXIA01
AXIA01(config)#
Assigning an IP address to Vlan 1
By default Livewire uses Vlan 1. It is possible to use other Vlans, however, support for that is outside of the scope of this document. Please contact your Cisco dealer, Cisco support, or your IT Group for assistance on using other Vlans.
To set the IP address, type the following from the prompt (replace the IP address shown with one that is appropriate to your configuration):
AXIA01>enable
AXIA01#config terminal
AXIA01(config)#interface vlan1
AXIA01(config-if)#ip address 192.168.2.2 255.255.255.0
AXIA01(config-if)#no shutdown
AXIA01(config-if)#exit
Let’s save our configuration:
AXIA01#wr
Building configuration...
[OK]
AXIA01#
Allow access from Telnet or SSH
Again we suggest the use of a password that is easy to remember. In this case “telnet123” is used as the password.
By default, the switch will only allow SSH.
- The line
transport input all
below allows both Telnet AND SSH protocols. - To enable ONLY telnet use
transport input telnet
- To enable ONLY SSH, omit the line
transport input all
from these commands and SSH is assumed
AXIA01(config)#line vty 0 15
AXIA01(config-line)#password telnet123
AXIA01(config-line)#transport input all
AXIA01(config-line)#login
AXIA01(config-line)#exit
Configuring Global QoS
Setup QoS Classes
AXIA01#config t
AXIA01 (config)#class-map LIVEWIRE
AXIA01 (config-cmap)#match ip dscp cs6
AXIA01 (config-cmap)#exit
AXIA01 (config)#class-map STANDARD_ST
AXIA01 (config-cmap)#match ip dscp ef af41
AXIA01 (config-cmap)#exit
AXIA01 (config)#policy-map TELOS
AXIA01 (config-pmap)#class LIVEWIRE
AXIA01 (config-pmap-c)#priority level 1
AXIA01 (config-pmap-c)#queue-buffers ratio 20
AXIA01 (config-pmap-c)#exit
AXIA01 (config-pmap)#class STANDARD_ST
AXIA01 (config-pmap-c)#priority level 2
AXIA01 (config-pmap-c)#queue-buffers ratio 70
AXIA01 (config-pmap-c)#exit
AXIA01 (config-pmap)#class class-default
AXIA01 (config-pmap-c)#bandwidth remaining percent 50
AXIA01 (config-pmap-c)#end
Setup IGMP
AXIA01#config terminal
AXIA01(config)#ip igmp snooping querier
AXIA01(config)#ip igmp snooping vlan 1 immediate-leave
AXIA01(config)#ip igmp snooping querier max-response-time 25
AXIA01(config)#ip igmp snooping querier timer expiry 205
AXIA01(config)#ip igmp snooping tcn query solicit
AXIA01(config)#ip igmp snooping tcn flood query count 1
AXIA01(config)#end
To disable ip igmp querier on a Cisco switch use:
AXIA01#config terminal
AXIA01(config)#no ip igmp snooping querier
AXIA01(config)#end
Configuring Axia Device Ports (Access Ports)
Access ports are used for connecting “endpoint” devices like Axia nodes, engines, computers, as well as any other devices that are not considered “switches” (see note in trunk port configuration section).
To configure multiple access ports at once, type the following from the prompt:
AXIA01#config terminal
AXIA01(config)#interface range GigabitEthernet1/0/1 - 22
AXIA01(config-if-range)#switchport mode access
AXIA01(config-if-range)#switchport nonegotiate
AXIA01(config-if-range)#switchport voice vlan dot1p
AXIA01(config-if-range)#spanning-tree portfast
AXIA01(config-if-range)#no ip igmp snooping tcn flood
AXIA01(config-if-range)#service-policy output TELOS
AXIA01(config-if-range)#no power efficient-ethernet auto
AXIA01(config-if-range)#end
Configuring Trunk Ports
Trunk ports are used for connecting other Cisco switches or Axia devices with switches built-in (like a PowerStation Main or QOR or xSwitch). Please note that when connecting to a PowerStation Main, only the GIG ports can be used and they must be properly configured for Trunk operation in the Ethernet Switch configuration of the Element Control Center. QOR-based devices and xSwitch should only be connected to the GIG Ports.
To configure multiple trunk ports at once, type the following from the prompt:
AXIA01#config t
AXIA01(config)#interface range GigabitEthernet1/0/23 - 24
AXIA01(config-if-range)#switchport mode trunk
AXIA01(config-if-range)#switchport trunk allowed vlan 1
AXIA01(config-if-range)#service-policy output TELOS
AXIA01(config-if-range)#no ip igmp snooping tcn flood
AXIA01(config-if-range)#no power efficient-ethernet auto
AXIA01(config-if-range)#end
Set Spanning-Tree settings
It’s important for your core switch to be set up as the master for the Spanning Tree protocol. If this switch will be the core switch for your Axia network then set it as the Spanning Tree root.
AXIA01#config t
AXIA01(config)#spanning-tree vlan 1 root primary
AXIA01(config)#end
Save and Check Your Work
To save your work type the following;
AXIA01#copy running-config startup-config
You will be prompted for a file name. Just press enter.
Destination filename [startup-config]?
Building configuration...
[OK]
AXIA01#
To check your work, from the command prompt, type;
AXIA01#show run
Use the spacebar to proceed a page at a time and double-check your configuration.
Let us know how we can help
If you have further questions on this topic or have ideas about improving this document please contact us