Configuring Cisco Catalyst 3650 & 3850 for use with Livewire

Updated by Bryan Jones

WARNING - We have become aware of an issue with a particular version of firmware on these switches which could materially affect the operation of your network. Please review this document for more information.

Scope

This document covers the configuration of the Cisco 3650 and 3850 series of switches for use with a Livewire+ network. While we do list the SPECIFIC switch used, it's important to note that most variants of this switch that run LanBase software will work for Livewire.

This switch has been tested and the configuration is based on the following;

  • Cisco model: WS-C3650-24TS-L
  • Serial Number: FDO1915E0C2
  • Software version at the time of testing: 03.03.05SE
Please note that this document applies only to the Cisco 3650 and 3850 series of switches. While some of these settings will work with other switches, using these commands to program switches that are not in this series could yield unintended results.

Introduction

This document is not intended to be an all-inclusive or even a step-by-step manual on how to configure this switch but is provided as a guide and makes some basic assumptions regarding the skill level of the person doing the programming. If you are not comfortable hooking up serial cables, assigning IP addresses, typing in a command-line interface, you should contact your IT department for assistance. If this is the first time the switch has been configured, you will have to connect to the switch via a console cable and serial connection to enter into setup. After the initial configuration of the switch, you can connect to the switch either via a Telnet session or through a serial port. During the initial setup, you will assign the switch to an IP address, which will then allow you to connect to the switch via a Telnet session at a later time. You can connect to this switch using a USB cable and a serial port driver from Cisco. As of the date of this writing, the usb driver can be obtained from the Cisco website. Make sure you install the driver before connecting the switch to your USB ports. This will install a new COM port on your computer.PuTTy is a free terminal program that can be used for configuration and can be downloaded here.

Programming

Once connected with the serial cable (default settings are 9600 baud), you should be able to see messages on the screen as the switch boots. This will confirm that your serial cable is working correctly. If you are prompted to enter any setup wizards, please answer ‘No’.A couple of other notes that might be helpful:

  • Many commands can be abbreviated and just need to be unambiguous. For example, the ‘enable’ command is often abbreviated as ‘en’, and ‘configure terminal’ is often abbreviated as ‘config t’. All commands can be abbreviated.
  • The TAB key completes a word and checks it for correctness. For example, if you type ‘en’ and then press TAB it will spell out the word ‘enable’.
  • The # (pound or hash sign) indicates you are in privileged mode. For example, if your prompt says Switch> and you try to type config t, you will receive an error because you are not in privileged mode. Typing the enable command will give you the Switch# prompt indicating you have entered privileged mode.

Set the passwords

We suggest using a password of ‘Livewire’ or some other password that is easy to remember.

Switch>enable
Switch#configure terminal
Switch(config)#username AAAA password Livewire
Switch(config)#enable password Axia

Set the Hostname

We suggest setting the hostname of each switch to something descriptive. Suggestions might be AXIACORE01, or AXIAEDGE01, etc. In this example, we will use AXIA01.

To change the hostname from the default of ‘Switch’, type the following from the prompt;

Switch(config)#hostname AXIA01
AXIA01(config)#

Set the IP Address on VLAN 1

By default, Livewire uses Vlan 1. It is possible to use other Vlans, however, support for that is outside of the scope of this document. Please contact your Cisco dealer, Cisco support, or your IT Group for assistance on using other Vlans.

By default, the IGMP Querier will be the lowest IP address switch in the subnet. For this reason, it is important to set your core switch with a lower IP than any other switch in the Livewire subnet. Note, that this includes any PowerStation, QOR, or xSwitch as well as other Cisco switches.

To set the IP address, type the following from the prompt (replace the IP address shown with one that is appropriate to your configuration):

AXIA01>enable
AXIA01#config terminal
AXIA01(config)#interface vlan1
AXIA01(config-if)#ip address 192.168.2.2 255.255.255.0
AXIA01(config-if)#no shutdown
AXIA01(config-if)#exit

Let’s save our configuration:

AXIA01#wr
Building configuration...
[OK]
AXIA01#

Set access from Telnet

Again we suggest the use of a password that is easy to remember.  In this case, “telnet123” is used as the password.

AXIA01(config)#line vty 0 15
AXIA01(config-line)#password telnet123
AXIA01(config-line)#login
AXIA01(config-line)#exit

Configure Global QoS

Set up QoS Classes
AXIA01#config t
AXIA01 (config)#class-map LIVEWIRE
AXIA01 (config-cmap)#match ip dscp cs6
AXIA01 (config-cmap)#exit
AXIA01 (config)#class-map STANDARD_ST
AXIA01 (config-cmap)#match ip dscp af41 ef
AXIA01 (config-cmap)#exit
AXIA01 (config)#policy-map TELOS
AXIA01 (config-pmap)#class LIVEWIRE
AXIA01 (config-pmap-c)#priority level 1
AXIA01 (config-pmap-c)#queue-buffers ratio 20
AXIA01 (config-pmap-c)#exit
AXIA01 (config-pmap)#class STANDARD_ST
AXIA01 (config-pmap-c)#priority level 2
AXIA01 (config-pmap-c)#queue-buffers ratio 70
AXIA01 (config-pmap-c)#exit
AXIA01 (config-pmap)#class class-default
AXIA01 (config-pmap-c)#bandwidth remaining percent 50
AXIA01 (config-pmap-c)#end

Configure IGMP

AXIA01#config terminal
AXIA01(config)#ip igmp snooping querier
AXIA01(config)#ip igmp snooping vlan 1 immediate-leave
AXIA01(config)#ip igmp snooping querier max-response-time 25
AXIA01(config)#ip igmp snooping querier timer expiry 205
AXIA01(config)#end
It is recommended to set only one “ip igmp snooping querier” per VLAN and for proper operation, the querier must be core switch. (core switch is defined as the “central” switch or the one that all other switches connect to).  This is particularly important in cases where the total bandwidth on a Livewire network can exceed the capacity of any single link.  

To disable IGMP querier on a Cisco switch use:

AXIA01#config terminal
AXIA01(config)#no ip igmp snooping querier
AXIA01(config)#end

Configure Access Ports (Axia Device Ports)

Access ports are used for connecting “endpoint” devices like Axia nodes, engines, computers, as well as any other devices that are not considered “switches” (see note in trunk port configuration section). 

 To configure multiple access ports at once, type the following from the prompt:

Replace GigabitEthernet1/0/1 - 22 with the ports that are appropriate to your configuration. In this example, we are configuring ports 1 thru 22 as access ports.
AXIA01#config terminal
AXIA01(config)#interface range GigabitEthernet1/0/1 - 22
AXIA01(config-if-range)#switchport mode access
AXIA01(config-if-range)#switchport nonegotiate
AXIA01(config-if-range)#switchport voice vlan dot1p
AXIA01(config-if-range)#spanning-tree portfast
AXIA01(config-if-range)#no ip igmp snooping tcn flood
AXIA01(config-if-range)#service-policy output TELOS
If your switch supports Cisco's new Energy Efficient Ethernet protocol, we want to disable that on all ports now. The following command does this. If you receive an error while entering this command it simply means your switch or software does not support it so the error is okay. For more information on Cisco EEE please refer to this document.
AXIA01(config-if-range)#no power efficient-ethernet auto
AXIA01(config-if-range)#end

Configure Trunk Ports

Trunk ports are used for connecting other Cisco switches or Axia devices with switches built-in (like a PowerStation Main or QOR or xSwitch). Please note that when connecting to a PowerStation Main, only the GIG ports can be used and they must be properly configured for Trunk operation in the Ethernet Switch configuration of the Element Control Center. QOR based devices and xSwitch should only be connected to the GIG Ports.

 To configure multiple trunk ports at once, type the following from the prompt:

Replace GigabitEthernet1/0/23 - 24 with the ports that are appropriate to your configuration. In this example, we are configuring ports 23 and 24 for Trunk.
AXIA01# config t
AXIA01(config)#interface range GigabitEthernet1/0/23 - 24
AXIA01(config-if-range)#switchport mode trunk
AXIA01(config-if-range)#switchport trunk allowed vlan 1
AXIA01(config-if-range)# service-policy output TELOS
AXIA01(config-if-range)# no ip igmp snooping tcn flood
AXIA01(config-if-range)#no power efficient-ethernet auto
AXIA01(config-if-range)#end
Note the inclusion of the Cisco EEE disabling command as we did in the Access ports. Again, an error when entering this command is possible and expected if not supported by the switch.

Configure Spanning Tree Settings

It’s important for your core switch to be set up as the master for the Spanning Tree protocol. If this switch will be the core switch for your Axia network then set it as the Spanning Tree root.

AXIA01# config t
AXIA01(config)#spanning-tree vlan 1 root primary
AXIA01(config)#end

Save and check your work

To save your work type the following;

AXIA01#copy running-config startup-config

You will be prompted for a file name.  Just press enter.

Destination filename [startup-config]?
Building configuration...
[OK]
AXIA01#

To check your work, from the command prompt, type;

AXIA01#show run

Use the spacebar to proceed with a page at a time and double-check your configuration.

Let us know how we can help

If you have further questions on this topic or have ideas about improving this document please contact us


How did we do?