VOCO 8 stuck during upgrade process (after CMOS battery was replaced)
Scope
During the VOCO8's lifespan, you might need to replace its CMOS battery, especially if the unit has been unplugged for an extended period. If the VOCO8 doesn't turn on automatically when connected to power, this is a sign that the battery may need replacement. However, note that after changing the CMOS battery, the system's date and time will reset, which can create problems when attempting a software update
Issue when trying to update
Symptom Summary:
When you plug in a USB thumb-drive containing the update package, the VOCO scans it and prompts you with a dialogue to choose the update package. After this action, the front panel displays "Checking upgrade in progress" and freezes. Although the unit still works, you cannot access the front panel. The only solution is to reboot by unplugging and restarting the VOCO to get the front panel control back. The update never completes
Cause of the issue
The update procedure checks the timestamps of the files inside the update package. If the CMOS battery was removed, the system time resets to a 2010 timestamp. Since the update packages have file timestamps well after 2010, this mismatch causes the updater to freeze.
Solution to issue
The system clock needs to be set to the current date. Unfortunately VOCO8 has no method from the front panel or remote gateway application to set the system date and time. It must be done from BIOS. The VOCO8 does try to sync to NTP, but it attempts to use a predefined public NTP server. Typically the VOCO8 unit does not have internet access to sync to NTP with
To manually set the system date/time from BIOS:
- Connect a USB keyboard to the front panel USB port of VOCO
- From the front panel, go to System Menu and select Reboot Option. Enter the admin password (default is admin) and hit OK
- Start tapping the DEL on the keyboard until the BIOS menu is displayed
- Arrow Down to Date and press + to increment month, then press Tab to go to the next value and repeat
- Go to the Exit menu and select Exit Saving Changes. Remove USB keyboard
- After VOCO has been booted up again, re-attempt the USB upgrade process
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