Can my Omnia.11 be upgraded to G-Force and Perfect Declipper

Updated 5 months ago by Bryan Jones

SCOPE

This article applies to ALL models of the Omnia.11 audio processor.

DESCRIPTION

We are often asked which Omnia.11 audio processors can be upgraded to run G-Force and Perfect Declipper.

The short answer is, all of them can be upgraded.

UPGRADE PROCESS

All new Omnia.11 audio processors come standard with G-Force enabled. There is no upgrade needed. Perfect Declipper is a paid upgrade and G-Force is required.

Both FM+HD and FM-only models can be upgraded with the optional Perfect Declipper Plug-In, a revolutionary new algorithm engineered by audio-processing legend Hans van Zutphen that restores clipped areas in audio recordings. This algorithm not only restores dynamics but removes distortion. Contact your Omnia dealer and ask for part number 3001-00069-000: (Omnia.11 Perfect Declipper Plugin)

The upgrade process depends a bit on what version you are running now. Read on.

G-Force represents a completely new processing engine. Your current Omnia.11 Presets used in the traditional "Orange" flavor are not compatible with G-Force.

If you are running;

Version 3.0 or higher.

You are good to go here. We do recommend updating to the latest update. As of this writing, that version is 3.6r222. You can download the update instructions here.

If your processor did not come with G-Force enabled, please contact your dealer and ask for Omnia part number 3001-00068-000 (Omnia.11 G-Force Processing Engine Plugin). Activation is done using a hardware ID file / activation file.

If your version is not already 3.0 but is 1.5 or higher.

You must update to version 3 or higher to enable G-Force. Please download the update instructions for version 3 here. Once complete you can activate G-Force on your unit. Please contact your dealer and ask for Omnia part number 3001-00068-000 (Omnia.11 G-Force Processing Engine Plugin). Activation is done using a hardware ID file / activation file once your purchase is completed.

If you are running a version LOWER than 1.5.

Version 1.5 was released in 2014 as a compact flash card update. This new CF card is required in order to update to version 3.x. If your unit is running version 1.4 or earlier, please contact Telos Support to obtain the necessary compact flashcard(s) and instructions.


How did we do?


TelosHelp (opens in a new tab)

Powered by HelpDocs (opens in a new tab)