Configuring the Cisco Catalyst 2960X/CX Series of Switches for Livewire®

Updated by Bryan Jones

Scope

Please note that this document applies only to the Cisco 2960X series of switches. While some of these settings will work with other switches, using these commands to program switches, not in this series, could yield unintended results.

This document is not an all-inclusive or even step-by-step on how to configure this network switch. It is provided guide. This document makes underlying assumptions regarding the skill level of the person doing the programming. If you are not comfortable hooking up serial cables, assigning IP addresses, typing in a command-line interface, etc., you should contact your IT department for assistance.

Configuration

If this is the first-time configuration, you will have to connect to the switch via a console cable and serial connection to enter into setup. Once setup is complete, you can connect to the switch either via a Telnet session or through a serial port. During the initial setup, you will assign the switch to an IP address, which will then allow you to connect to the switch via a Telnet session at a later time.

You can connect to this switch using a USB cable and a serial port driver from Cisco. As of the date of this writing, you can obtain the USB driver from the Cisco website. Make sure you install the driver before connecting the switch to your USB ports. Installing the Cisco software will introduce a new COM port on your computer.

PuTTy is a free terminal program you can use for configuration. You can download PuTTy here.

Testing and configuration is based on the following;

  • Cisco model: WS-C2960X-24TS-L
  • Version ID: V02
  • Software: 15.0(2)EX5

Programming

Once connected with the serial cable (default settings are 9600 baud), you should be able to see messages on the screen as the switch boots. The on-screen messages confirm that your serial cable is working correctly. If prompted to enter any setup wizards, please answer ‘No.’

A couple of other notes that might be helpful:
  • Many commands can be abbreviated and just need to be unambiguous. For example, abbreviate the ‘enable’ command as ‘en,’ ‘configure terminal’ is abbreviated as ‘config t.’ You can abbreviate all commands.
  • The TAB key completes a word and checks it for correctness. For example, if you type ‘en’ and then press TAB, it will spell out the word ‘enable.’
  • The # (pound or hash sign) indicates you are in privileged mode. For example, if your prompt says switch> and you try to type config t, you will receive an error because you are not in privileged mode. Typing the enable command will give you the Switch# prompt indicating the privileged mode.

Set Passwords

We suggest using a password of ‘Livewire’ or some other password that is easy to remember.

Switch>enable
Switch#configure terminal
Switch(config)#username AAAA password Livewire
Switch(config)#enable password Axia

Set a descriptive Hostname

We suggest setting the hostname of each switch to something descriptive. Suggestions might be AXIACORE01, or AXIAEDGE01, etc. In this example, we will use AXIA01.

To change the hostname from the default of ‘Switch,' type the following from the prompt;

Switch(config)#hostname AXIA01
AXIA01(config)#

Set the Vlan 1 IP Address

By default, Livewire uses Vlan 1. It may be possible to use other Vlans; however, support for that is outside of the scope of this document. Please contact your Cisco dealer or Cisco for support on using other Vlans.

By default, the IGMP Querier will be the lowest IP address switch in the subnet. For this reason, it is important to set your core switch lower than any other switch. Note that this includes any Power Station, QOR, or xSwtich as well.

To set the IP address, type the following from the prompt (replace the IP address shown with one that is appropriate to your configuration):

AXIA01(config)#interface vlan1
AXIA01(config-if)#ip address 192.168.2.2 255.255.255.0
AXIA01(config-if)#no shutdown
AXIA01(config-if)#end

Let’s save our configuration:

AXIA01#wr
Building configuration...
[OK]
AXIA01#

CONFIGURE IGMP

To configure IGMP, type the following from the prompt:

AXIA01#config terminal
AXIA01(config)#ip igmp snooping querier
AXIA01(config)#ip igmp snooping vlan 1 immediate-leave
AXIA01(config)#ip igmp snooping querier max-response-time 25
AXIA01(config)#ip igmp snooping querier timer expiry 205

CONFIGURING GLOBAL QoS

AXIA01(config)#mls qos srr-queue output cos-map queue 1 threshold 1 6 7
AXIA01(config)#mls qos srr-queue output cos-map queue 2 threshold 1 5
AXIA01(config)#mls qos srr-queue output cos-map queue 3 threshold 1 0 1
AXIA01(config)#mls qos srr-queue output dscp-map queue 1 threshold 1 48
AXIA01(config)#mls qos srr-queue output dscp-map queue 2 threshold 1 46 34
AXIA01(config)#mls qos srr-queue output dscp-map queue 3 threshold 1 0
AXIA01(config)#mls qos map cos-dscp 0 8 16 24 34 46 48 56
AXIA01(config)#mls qos queue-set output 1 buffers 20 70 5 5
AXIA01(config)#mls qos
AXIA01(config)#end
AXIA01#wr
Building configuration...
[OK]
AXIA01#

CONFIGURING ACCESS PORTS

Use Access ports for connecting “endpoint” devices like Axia nodes, engines, computers, as well as any other devices that are not considered “switches” (see note in trunk port configuration section).

To configure multiple access ports at once, type the following from the prompt:

*Note - Replace GigabitEthernet1/0/1 - 22 with the ports that are appropriate to your configuration. In this example, we are configuring ports 1 thru 24 as access ports.
*Tip - If using CX model without the Stacked Switches use GigabitEthernet0/1 - 22 syntax. Using the ports that are appropriate to your configuration. In this example, we are configuring ports 1 thru 24 as access ports.
AXIA01#config terminal
AXIA01(config)#interface range GigabitEthernet1/0/1 - 22
AXIA01(config-if-range)#switchport mode access
AXIA01(config-if-range)#switchport nonegotiate
AXIA01(config-if-range)#switchport voice vlan dot1p
AXIA01(config-if-range)#priority-queue out
AXIA01(config-if-range)#spanning-tree portfast
AXIA01(config-if-range)#mls qos trust dscp *SEE NOTE BELOW*
AXIA01(config-if-range)#no ip igmp snooping tcn flood
*NOTE* - for Engine, iPort, VX, or Omnia 8x versions older than 2011-06-15 use “mls qos trust cos”
If your switch supports Cisco's new Energy Efficient Ethernet protocol, we want to disable that on all ports now . The following command does this. If you receive an error while entering this command it simply means your switch or software does not support it so the error is okay. For more information on Cisco EEE please refer to this document.
AXIA01(config-if-range)#no power efficient-ethernet auto
AXIA01(config-if-range)#end

Alternately, to configure a single access port, type the following from the prompt:

*Note - Replace GigabitEthernet1/0/1 with the port that is appropriate to your configuration.

In this example, we are configuring port 1 as an Access port.

AXIA01#config terminal
AXIA01(config)#interface GigabitEthernet1/0/1
AXIA01(config-if)#switchport mode access
AXIA01(config-if)#switchport nonegotiate
AXIA01(config-if)#switchport voice vlan dot1p
AXIA01(config-if)#priority-queue out
AXIA01(config-if)#spanning-tree portfast
AXIA01(config-if)#mls qos trust dscp *SEE NOTE BELOW*
AXIA01(config-if)#no ip igmp snooping tcn flood
*NOTE* - for Engine, iPort, VX, or Omnia 8x versions older than 2011-06-15 use “mls qos trust cos”
If your switch supports Cisco's new Energy Efficient Ethernet protocol, we want to disable that on all ports now . The following command does this. If you receive an error while entering this command it simply means your switch or software does not support it so the error is okay. For more information on Cisco EEE please refer to this document.
AXIA01(config-if)#no power efficient-ethernet auto
AXIA01(config-if)#end

CONFIGURING TRUNK PORTS

Use Trunk ports for connecting other switches or Axia devices with switches built-in (like a PowerStation Main or QOR or xSwitch). Please note that when connecting to a PowerStation Main, only the GIG ports can be used and they must be properly configured for Trunk operation in the Ethernet Switch configuration of the Element Control Center.

QOR based devices and xSwitch should only be connected to the GIG Ports on the back of their respective units.

To configure multiple trunk ports at once, type the following from the prompt:

*Note - Replace GigabitEthernet1/0/23 - 24 with the ports that are appropriate to your configuration. In this example, we are configuring ports 23 and 24 for Trunk.
*Tip - If using a CX model with the Stacked Feature use GigabitEthernet0/23 - 24 syntax. Using the ports that are appropriate to your configuration. In this example, we are configuring ports 23 and 24 for Trunk.
AXIA01#config t
AXIA01(config)#interface range GigabitEthernet1/0/23 - 24
AXIA01(config-if-range)#switchport mode trunk
AXIA01(config-if-range)#priority-queue out
AXIA01(config-if-range)#mls qos trust dscp
AXIA01(config-if-range)#end
AXIA01#

Alternately, to configure a single trunk port, type the following from the prompt:

*Note - Replace GigabitEthernet1/0/23 with the port that is appropriate to your configuration. In this example, we are configuring port 23 for Trunk.
AXIA01#config t
AXIA01(config)#interface GigabitEthernet1/0/23
AXIA01(config-if)#switchport mode trunk
AXIA01(config-if)#priority-queue out
AXIA01(config-if)#mls qos trust dscp
AXIA01(config-if)#end
AXIA01#wr
Building configuration...
[OK]
AXIA01#

CONFIGURING TELNET ACCESS

To configure telnet access, type the following from the prompt:

AXIA01#configure terminal
AXIA01(config)#line vty 0 15
AXIA01(config-line)#password Livewire
AXIA01(config-line)#login
AXIA01(config-line)#end
AXIA01#wr
Building configuration...
[OK]
AXIA01#

Save and Check Your Work

To save your work type the following;

AXIA01#copy running-config startup-config

You will be prompted for a file name.  Just press enter.

Destination filename [startup-config]?
Building configuration...
[OK]
AXIA01#

To check your work, from the command prompt, type;

AXIA01#show run

Use the spacebar to proceed a page at a time and double check your configuration.CHECK YOUR CONFIGURATION.

Let us know how we can help

If you have further questions on this topic or have ideas about improving this document please contact us


How did we do?